final class Ipv6Address extends IpAddress with Ipv6AddressPlatform
Representation of an IPv6 address that works on both the JVM and Scala.js.
- Source
- IpAddress.scala
- Alphabetic
- By Inheritance
- Ipv6Address
- Ipv6AddressPlatform
- IpAddress
- Serializable
- Serializable
- IpAddressPlatform
- AnyRef
- Any
- by any2stringadd
- by StringFormat
- by Ensuring
- by ArrowAssoc
- Hide All
- Show All
- Public
- All
Value Members
-
final
def
!=(arg0: Any): Boolean
- Definition Classes
- AnyRef → Any
-
final
def
##(): Int
- Definition Classes
- AnyRef → Any
-
def
+(other: String): String
- Implicit
- This member is added by an implicit conversion from Ipv6Address to any2stringadd[Ipv6Address] performed by method any2stringadd in scala.Predef.
- Definition Classes
- any2stringadd
-
def
->[B](y: B): (Ipv6Address, B)
- Implicit
- This member is added by an implicit conversion from Ipv6Address to ArrowAssoc[Ipv6Address] performed by method ArrowAssoc in scala.Predef.
- Definition Classes
- ArrowAssoc
- Annotations
- @inline()
-
def
/(prefixBits: Int): Cidr[Ipv6Address.this.type]
Constructs a Cidr address from this address.
-
final
def
==(arg0: Any): Boolean
- Definition Classes
- AnyRef → Any
-
final
def
asInstanceOf[T0]: T0
- Definition Classes
- Any
-
def
asIpv4: Option[Ipv4Address]
Narrows this address to an Ipv4Address if that is the underlying type.
Narrows this address to an Ipv4Address if that is the underlying type.
- Definition Classes
- IpAddress
-
def
asIpv6: Option[Ipv6Address]
Narrows this address to an Ipv6Address if that is the underlying type.
Narrows this address to an Ipv6Address if that is the underlying type.
- Definition Classes
- IpAddress
-
def
asMulticast: Option[Multicast[Ipv6Address.this.type]]
Converts this address to a multicast address, as long as it is in the multicast address range.
Converts this address to a multicast address, as long as it is in the multicast address range.
- Definition Classes
- IpAddress
-
def
asSourceSpecificMulticast: Option[SourceSpecificMulticast[Ipv6Address.this.type]]
Converts this address to a source specific multicast address, as long as it is in the source specific multicast address range.
Converts this address to a source specific multicast address, as long as it is in the source specific multicast address range.
- Definition Classes
- IpAddress
-
val
bytes: Array[Byte]
- Attributes
- protected
- Definition Classes
- Ipv6Address → Ipv6AddressPlatform → IpAddress
-
def
clone(): AnyRef
- Attributes
- protected[java.lang]
- Definition Classes
- AnyRef
- Annotations
- @native() @throws( ... )
-
def
ensuring(cond: (Ipv6Address) ⇒ Boolean, msg: ⇒ Any): Ipv6Address
- Implicit
- This member is added by an implicit conversion from Ipv6Address to Ensuring[Ipv6Address] performed by method Ensuring in scala.Predef.
- Definition Classes
- Ensuring
-
def
ensuring(cond: (Ipv6Address) ⇒ Boolean): Ipv6Address
- Implicit
- This member is added by an implicit conversion from Ipv6Address to Ensuring[Ipv6Address] performed by method Ensuring in scala.Predef.
- Definition Classes
- Ensuring
-
def
ensuring(cond: Boolean, msg: ⇒ Any): Ipv6Address
- Implicit
- This member is added by an implicit conversion from Ipv6Address to Ensuring[Ipv6Address] performed by method Ensuring in scala.Predef.
- Definition Classes
- Ensuring
-
def
ensuring(cond: Boolean): Ipv6Address
- Implicit
- This member is added by an implicit conversion from Ipv6Address to Ensuring[Ipv6Address] performed by method Ensuring in scala.Predef.
- Definition Classes
- Ensuring
-
final
def
eq(arg0: AnyRef): Boolean
- Definition Classes
- AnyRef
-
def
equals(other: Any): Boolean
- Definition Classes
- IpAddress → AnyRef → Any
-
def
finalize(): Unit
- Attributes
- protected[java.lang]
- Definition Classes
- AnyRef
- Annotations
- @throws( classOf[java.lang.Throwable] )
-
def
fold[A](v4: (Ipv4Address) ⇒ A, v6: (Ipv6Address) ⇒ A): A
Converts this address to a value of type
Ausing the supplied functions.Converts this address to a value of type
Ausing the supplied functions.- Definition Classes
- Ipv6Address → IpAddress
-
def
formatted(fmtstr: String): String
- Implicit
- This member is added by an implicit conversion from Ipv6Address to StringFormat[Ipv6Address] performed by method StringFormat in scala.Predef.
- Definition Classes
- StringFormat
- Annotations
- @inline()
-
final
def
getClass(): Class[_]
- Definition Classes
- AnyRef → Any
- Annotations
- @native()
-
def
hashCode(): Int
- Definition Classes
- IpAddress → AnyRef → Any
-
final
def
isInstanceOf[T0]: Boolean
- Definition Classes
- Any
-
def
isMulticast: Boolean
Returns true if this address is in the multicast range.
Returns true if this address is in the multicast range.
- Definition Classes
- Ipv6Address → IpAddress
-
def
isSourceSpecificMulticast: Boolean
Returns true if this address is in the source specific multicast range.
Returns true if this address is in the source specific multicast range.
- Definition Classes
- Ipv6Address → IpAddress
-
def
masked(mask: Ipv6Address): Ipv6Address
Applies the supplied mask to this address.
Applies the supplied mask to this address.
scala> ipv6"ff3b::1".masked(ipv6"fff0::") res0: Ipv6Address = ff30::
Example: -
def
maskedLast(mask: Ipv6Address): Ipv6Address
Computes the last address in the network identified by applying the supplied mask to this address.
Computes the last address in the network identified by applying the supplied mask to this address.
scala> ipv6"ff3b::1".maskedLast(ipv6"fff0::") res0: Ipv6Address = ff3f:ffff:ffff:ffff:ffff:ffff:ffff:ffff
Example: -
final
def
ne(arg0: AnyRef): Boolean
- Definition Classes
- AnyRef
-
def
next: Ipv6Address
Gets the IPv6 address after this address, with overflow from
ffff:ffff:....:ffffto::.Gets the IPv6 address after this address, with overflow from
ffff:ffff:....:ffffto::.- Definition Classes
- Ipv6Address → IpAddress
-
final
def
notify(): Unit
- Definition Classes
- AnyRef
- Annotations
- @native()
-
final
def
notifyAll(): Unit
- Definition Classes
- AnyRef
- Annotations
- @native()
-
def
previous: Ipv6Address
Gets the IPv6 address before this address, with underflow from
::toffff:ffff:....:ffff.Gets the IPv6 address before this address, with underflow from
::toffff:ffff:....:ffff.- Definition Classes
- Ipv6Address → IpAddress
-
final
def
synchronized[T0](arg0: ⇒ T0): T0
- Definition Classes
- AnyRef
-
def
toBigInt: BigInt
Converts this address to a 128-bit unsigned integer.
-
def
toBytes: Array[Byte]
Converts this address to a network order byte array of either 4 or 16 bytes.
Converts this address to a network order byte array of either 4 or 16 bytes.
- Definition Classes
- IpAddress
-
def
toInetAddress: Inet6Address
Converts this address to a
java.net.InetAddress.Converts this address to a
java.net.InetAddress. Note this method only exists on the JVM.- Definition Classes
- Ipv6AddressPlatform → IpAddressPlatform
-
def
toMixedString: String
Converts this address to a string of form
x:x:x:x:x:x:a.b.c.dwhere eachxrepresents 16-bits anda.b.c.dis IPv4 dotted decimal notation.Converts this address to a string of form
x:x:x:x:x:x:a.b.c.dwhere eachxrepresents 16-bits anda.b.c.dis IPv4 dotted decimal notation. Consecutive 0xfields are condensed with::.For example, the IPv4 address
127.0.0.1can be converted to a compatible IPv6 address via Ipv4Address#toCompatV6, which is represented as the string::7f00:1and the mixed string::127.0.0.1.Similarly,
127.0.0.1can be converted to a mapped V6 address via Ipv4Address#toMappedV6, resulting in::ffff:7f00:1and the mixed string::ffff:127.0.0.1.This format is described in RFC4291 section 2.2.3.
scala> ipv6"::7f00:1".toMixedString res0: String = ::127.0.0.1 scala> ipv6"ff3b:1234::ffab:7f00:1".toMixedString res0: String = ff3b:1234::ffab:127.0.0.1
Example: -
def
toString(): String
Returns the condensed string representation of the array per RFC5952.
Returns the condensed string representation of the array per RFC5952.
- Definition Classes
- Ipv6Address → AnyRef → Any
-
def
toUncondensedString: String
Returns an uncondensed string representation of the array.
-
def
toUriString: String
Converts this address to a string form that is compatible for use in a URI per RFC3986 (namely, IPv6 addresses are rendered in condensed form and surrounded by brackets).
Converts this address to a string form that is compatible for use in a URI per RFC3986 (namely, IPv6 addresses are rendered in condensed form and surrounded by brackets).
- Definition Classes
- Ipv6Address → IpAddress
-
def
transform(v4: (Ipv4Address) ⇒ Ipv4Address, v6: (Ipv6Address) ⇒ Ipv6Address): Ipv6Address.this.type
Maps a type-preserving function across this IP address.
Maps a type-preserving function across this IP address.
- Definition Classes
- Ipv6Address → IpAddress
-
final
def
wait(): Unit
- Definition Classes
- AnyRef
- Annotations
- @throws( ... )
-
final
def
wait(arg0: Long, arg1: Int): Unit
- Definition Classes
- AnyRef
- Annotations
- @throws( ... )
-
final
def
wait(arg0: Long): Unit
- Definition Classes
- AnyRef
- Annotations
- @native() @throws( ... )
-
def
→[B](y: B): (Ipv6Address, B)
- Implicit
- This member is added by an implicit conversion from Ipv6Address to ArrowAssoc[Ipv6Address] performed by method ArrowAssoc in scala.Predef.
- Definition Classes
- ArrowAssoc